mt-check.cgiはシステムの構成を確認し、Movable Typeを実行するために必要なコンポーネントがそろっていることを確認するためのスクリプトです。

システム情報

確認中: 必須モジュール

CGI::Cookie

サーバーに CGI::Cookie がインストールされています(バージョン 1.20)。

File::Spec (version >= 0.8)

サーバーに File::Spec がインストールされています(バージョン 3.40)。

Image::Size

サーバーに Image::Size がインストールされています(バージョン 2.93)。

CGI

サーバーに CGI がインストールされています(バージョン 2.80)。

確認中: データストレージモジュール

これらのモジュールは、Movable Type がデータを保存するために必要なモジュールです。DBIと、1つ以上のデータベース用のモジュールがインストールされている必要があります。

DBI (version >= 1.21)

サーバーに DBI がインストールされています(バージョン 1.627)。

DBD::mysql

サーバーに DBD::mysql がインストールされています(バージョン 4.023)。

DBD::SQLite

サーバーに DBD::SQLite がインストールされています(バージョン 1.39)。

DBD::Pg (version >= 1.32)

サーバーに DBD::Pg がインストールされています(バージョン 2.19.3)。

DBD::SQLite2

サーバーに DBD::SQLite2 がインストールされています(バージョン 0.37)。

確認中: オプションモジュール

これらのモジュールのインストールは任意です。お使いのサーバーにこれらのモジュールがインストールされていない場合でも、Movable Type の基本機能は動作します。これらのモジュールの機能が必要となった場合にはインストールを行ってください。

Crypt::DSA

サーバーに Crypt::DSAか、Crypt::DSAの動作に必要な他のモジュールがインストールされていません。 コメント投稿時のサインインが高速になります。 Crypt::DSAのインストールはインストールマニュアルに沿って行ってください。

XML::SAX

サーバーに XML::SAX がインストールされています(バージョン 0.13)。

Archive::Zip

サーバーに Archive::Zip がインストールされています(バージョン 1.30)。

Storable

サーバーに Storable がインストールされています(バージョン 2.45)。

SOAP::Lite (version >= 0.5)

サーバーに SOAP::Lite がインストールされています(バージョン 0.52)。

List::Util

サーバーに List::Util がインストールされています(バージョン 1.27)。

HTML::Entities

サーバーに HTML::Entities がインストールされています(バージョン 3.69)。

Archive::Tar

サーバーに Archive::Tar がインストールされています(バージョン 1.92)。

IO::Uncompress::Gunzip

サーバーに IO::Uncompress::Gunzip がインストールされています(バージョン 2.061)。

Digest::SHA1

サーバーに Digest::SHA1 がインストールされています(バージョン 2.13)。

IO::Compress::Gzip

サーバーに IO::Compress::Gzip がインストールされています(バージョン 2.061)。

Image::Magick

サーバーに Image::Magick がインストールされています(バージョン 6.78)。

XML::Atom

サーバーに XML::Atom がインストールされています(バージョン 0.25)。

LWP::UserAgent

サーバーに LWP::UserAgent がインストールされています(バージョン 2.001)。

Mail::Sendmail

サーバーに Mail::Sendmail がインストールされています(バージョン 0.79)。

MIME::Base64

サーバーに MIME::Base64 がインストールされています(バージョン 3.13)。

File::Temp

サーバーに File::Temp がインストールされています(バージョン 0.12)。

システムのチェックを完了しました。

Movable Typeを利用できます。 お使いのサーバーには、Movable Type の動作に必要なすべてのモジュールがインストールされています。モジュールを追加インストール作業は必要はありません。マニュアルに従い、インストールを続けてください。